Inter-VLAN routing

Categorie

Per inter-VLAN routing si intende l’inoltro di pacchetti tra host appartenenti a VLAN diverse, e quindi appartenenti a reti separate che necessitano di un router per comunicare tra loro. Il concetto è che per far comunicare VLAN distinte, tutte devono avere un gateway di riferimento che consenta il routing.  Sono disponibili tre soluzioni:

  1. Inter-VLAN tradizionale;
  2. “Router-on-a-stick” Inter-VLAN;
  3. Switch-based Inter-VLAN.

Inter-VLAN tradizionale

Per far comunicare due VLAN il modo più semplice è quello di inserire un router e connetterlo a uno degli switch della LAN: la connessione tra il router e lo switch deve essere fatta con un numero di interfacce fisiche pari al numero delle VLAN che devono poter comunicare tra di loro.  Dato che a ogni interfaccia fisica del router è associata a una VLAN, questa deve avere un indirizzo IP appartenente a tale VLAN.

routing tra vlan

Router-on-a-stick.

Per aggirare il problema di avere tante interfacce fisiche quante sono le VLAN da mettere in comunicazione, si utilizzano le sub-interfaces, ossia sotto-interfacce virtuali delle interfacce fisiche. Nell’immagine sottostante, si può vedere come l’interfaccia fisica fa0/0 sia stata suddivisa in 3 sub-interfaces, fa0/0.10, fa0/0.20, fa0/0.30. Nella forma di scrittura utilizzata, il valore dopo il punto indica dunque la sotto-interfaccia: convenzionalmente questo numero è uguale a quello della VLAN.

router-on-a-stick

Creazione di una sub-interface

Prima di tutto è necessario che l’interfaccia fisica principale sia attiva e priva di indirizzo IP dalla cli digitiamo:

Router(config)#interface ifa0/0
Router(config-if)#no ip address
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Router(config)#interface fa0/0.10
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.10.254 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fa0/0.20
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 192.168.20.254 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fa0/0.30
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.30, changed state to up

Router(config-subif)#encapsulation dot1q 30
Router(config-subif)#ip address 192.168.30.254 255.255.255.0
Router(config-subif)#

Multilayer switch

Alcuni switch possono eseguire funzioni di livello 3, sostituendo la necessità di un router dedicato per eseguire il routing di base in una rete. I multilayer switch sono in grado di eseguire l’instradamento fra VLAN. Per attivare uno switch multistrato per svolgere funzioni di routing:

  1. le interfacce VLAN sullo switch devono essere configurate con gli opportuni indirizzi IP che corrispondono alla subnet a cui la VLAN è associata nella rete.
  2. Lo switch multilayer deve anche avere il routing IP abilitato. 

 

layer 3 routing

Vantaggi nell’usare uno switch layer 3 al posto del router

  • Economico costo minore di uno switch rispetto ad un router multi porta
  • Prestazioni  maggiore velocità di inotro e istradamento dello swtch che fa queste operazione via hardware invece che via software come il router.

Vediamo i passaggi da effettuare per configurare la rete:

Sullo switch layer 3 creiamo le VLAN 10 20 e 30
switch# configure terminal
switch(config)# vlan 10
Switch(config-vlan)# exit
switch(config)# vlan 20
Switch(config-vlan)# exit
switch(config)# vlan 30
Switch(config-vlan)# exit

1) Dalla CLI abilitiamo il routing sullo switch layer 3

Switch(config)#ip routing
Switch(config)#

2) Impostiamo a trunk l’interfaccia fa0/1
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q
Layer3-Switch(config-if)# exit

3) Associamo alle interfacce VLan dello Switch gli indirizzi dei gateway delle singole vlan

Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.10.254 255.255.255.0

Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#ip address 192.168.20.254 255.255.255.0

Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 30
Switch(config-if)#ip address 192.168.30.254 255.255.255.0
SwiSwitch(config-if)#no shutdown

Resta da collegare queste VLAN ad internet, si deve aggiungere un router che va configurato normalmente ossia con:

  • un indirizzo ip della rete dell’isp
  • un indirizzo locale della rete interna

Poi si deve configurare la porta dello switch in questo modo:

  1. Si setta la porta verso il router (no switchport) come se fosse la porta di un router
  2. Si imposta l’indirizzo 
  3. si definisce come gateway il router

1) Configurazione della porta Gig0/1 dello switch

Switch(config)#interface gig0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.100.1 255.255.255.0
Switch(config-if)#

A questo punto lo switch multilayer deve prevedere una route di default verso il router:

Switch(config)# ip route 0.0.0.0 0.0.0.0 192.168.100.254

gateway di default per lo switch layer 3

2) Dobbiamo impostare la routing table sul router

routing table
Please follow and like us:

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

Wordpress Social Share Plugin powered by Ultimatelysocial
error

Enjoy this blog? Please spread the word :)

%d blogger hanno fatto clic su Mi Piace per questo: